buildroot/package/linux-pam/0001-configure.patch
Gustavo Zacarias c165b0e580 linux-pam: add security patches
To fix:
CVE-2013-7041 - use case sensitive comparison in pam_userdb
CVE-2014-2583 - potential path traversal issue in pam_timestamp

Also add hash file (computed, the hash files upstream cover up to 1.1.7)

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2014-12-18 22:55:00 +01:00

20 lines
769 B
Diff

Add check for ruserok
ruserok is not available/functional in uclibc, provide conditions for compilation
where needed.
Signed-off-by: Dmitry Golubovsky <golubovsky@gmail.com>
diff -urN a/configure.in b/configure.in
--- a/configure.in 2012-08-17 03:48:24.000000000 -0500
+++ b/configure.in 2013-07-17 09:49:23.760254684 -0500
@@ -526,7 +526,7 @@
AC_CHECK_FUNCS(strcspn strdup strspn strstr strtol uname)
AC_CHECK_FUNCS(getutent_r getpwnam_r getpwuid_r getgrnam_r getgrgid_r getspnam_r)
AC_CHECK_FUNCS(getgrouplist getline getdelim)
-AC_CHECK_FUNCS(inet_ntop inet_pton innetgr ruserok_af)
+AC_CHECK_FUNCS(inet_ntop inet_pton innetgr ruserok_af ruserok)
AC_CHECK_FUNCS(unshare, [UNSHARE=yes], [UNSHARE=no])
AM_CONDITIONAL([HAVE_UNSHARE], [test "$UNSHARE" = yes])