buildroot/package/sysdig/0001-remove-dkms-module-updater.patch
Angelo Compagnucci 74fc60a267 package/sysdig: New package
Sysdig is open source, system-level exploration: capture system state
and activity from a running Linux instance, then save, filter and
analyze.

[Thomas:
 - remove unneeded 0001-makefile-driver-compile-options.patch, instead
   pass KERNELDIR in the make options when building the driver, and
   pass the contents of $(LINUX_MAKE_FLAGS) directly.
 - use $(SYSDIG_BUILDDIR) instead of $(@D)/buildroot-build, so that
   the package does not depend on the package infra using specifically
   buildroot-build as the build subdirectory.
 - use $(MAKE) -C <foo> instead of cd <foo>; $(MAKE).
 - rename 0002 patch to 0001, since the 0001 patch is removed.]

Signed-off-by: Angelo Compagnucci <angelo.compagnucci@gmail.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Reviewed-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
Tested-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-03-30 22:30:51 +02:00

32 lines
773 B
Diff

Remove DKMS module updater
This patch disables the in target installation of DKMS module updater
mechanism unneeded in buildroot.
Signed-off-by: Angelo Compagnucci <angelo.compagnucci@gmail.com>
--- a/driver/CMakeLists.txt
+++ b/driver/CMakeLists.txt
@@ -39,21 +39,3 @@ add_custom_target(install_driver
WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
VERBATIM)
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/Makefile.dkms
- RENAME Makefile
- DESTINATION "src/sysdig-${SYSDIG_VERSION}")
-
-install(FILES
- ${CMAKE_CURRENT_BINARY_DIR}/dkms.conf
- dynamic_params_table.c
- event_table.c
- flags_table.c
- main.c
- ppm.h
- ppm_events.c
- ppm_events.h
- ppm_events_public.h
- ppm_fillers.c
- ppm_ringbuffer.h
- syscall_table.c
- DESTINATION "src/sysdig-${SYSDIG_VERSION}")