buildroot/package/unionfs/0001-fuse-no-cxx-needed.patch
Peter Korsgaard 298cd8eaa2 package/*: rename patches according to the new policy
Autogenerated from rename-patch.py (http://patchwork.ozlabs.org/patch/403345)

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2015-02-03 14:52:56 +01:00

20 lines
658 B
Diff

By default, CMake assumes a project uses the C and C++ languages, so
it checks for both the C and the C++ compiler to exist.
However, unionfs-fuse is written purely in C, so checking for a C++
compiler is useless, and even prevents unionfs-fuse from building
properly on targets for which no C++ compiler is available.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/CMakeLists.txt
===================================================================
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-project(unionfs-fuse)
+project(unionfs-fuse C)
cmake_minimum_required(VERSION 2.0)
INCLUDE (CheckIncludeFiles)